Guidewheel Platform Outage

Incident Report for Guidewheel

Resolved

We're continuing to see steady performance. Thank you for your patience and partnership.
Posted May 07, 2026 - 02:55 UTC

Update

We are seeing steady performance over the last hour.

We are continuing to monitor performance closely to address any remaining access or data problems.
Posted May 06, 2026 - 23:18 UTC

Monitoring

We have deployed another round of fixes and are seeing significantly improved performance.

We are continuing to run backfills to load data into the platform, and expect to fully recover all data from today.

We will update here once the all data has been restored.
Posted May 06, 2026 - 21:16 UTC

Investigating

We are continuing to see intermittent stoppages to service, and our engineering team is investigating additional potential solutions.

We are continuing to backfill data from the initial period of downtime.

Thank you for patience.
Posted May 06, 2026 - 19:24 UTC

Monitoring

We have deployed a fix for the underlying cause and are monitoring the results closely.
We are working on backfilling data from the period of the outage. We will update you here once we have an ETA for the backfill to be completed.
Posted May 06, 2026 - 16:56 UTC

Identified

Access to the system has been restored and new data is flowing again. We are working on a permanent fix for the underlying cause.

We are working on completing a data backfill and will have an ETA for completion in the next 30 minutes.
Posted May 06, 2026 - 15:37 UTC

Investigating

Degraded performance has recurred and some users are unable to access Guidewheel, or cannot see new data in their app.

Our team is investigating and we will update here in the next 30 minutes.
Posted May 06, 2026 - 15:17 UTC

Update

Our fix has been deployed and new data is flowing again and visible in the system.

We are working on completing a data backfill and will have an ETA for completion in the next 30 minutes.
Posted May 06, 2026 - 14:53 UTC

Update

Our engineering team has deployed a fix and data is beginning to process again. We expect the data from during the outage to be fully recovered within ~30 minutes.

We will post an update within 1 hour.
Posted May 06, 2026 - 14:11 UTC

Identified

Our engineering team has identified the source of the outage and is deploying a fix.

We will post an update within 1 hour.
Posted May 06, 2026 - 14:01 UTC

Investigating

We are currently experiencing a platform outage. The Guidewheel dashboard and data collection are unavailable for most customers.
Our team is actively investigating the cause and we will post an update within 1 hour.
Posted May 06, 2026 - 13:20 UTC
This incident affected: Guidewheel Portal.