The active incident with Google Cloud has been resolved. We are now recovering any data that needs to be recalculated and reprocessed from the period of time.
Posted Jun 13, 2025 - 01:04 UTC
Monitoring
Service across Google Cloud globally has been partially restored. We are seeing user access and data processing resume in the platform, and data recovery is beginning. We will continue to update this page when we know more.
Posted Jun 12, 2025 - 21:40 UTC
Update
We are continuing to investigate this issue.
Posted Jun 12, 2025 - 20:48 UTC
Investigating
A widespread Google Cloud outage is currently affecting many services across the internet, including parts of the Guidewheel platform. Because our data is stored on devices before going to the cloud, we do not expect any data loss due to the outage.